Jump to content


Photo

Service Light, Esp, Abs Lights And Faulty Parking Brake


  • Please log in to reply
5 replies to this topic

#1 adavies

adavies

    16 LX Newbie

  • Members
  • Pip
  • 1 posts

Posted 14 July 2012 - 07:54 PM

I've never been on the site before so please excuse the lack of jargon etc. We have a 58 plate c4 grand picasso and it's been great until this morning when the service light lit up at the roundabout, followed by the esp light and the abs light, and a notice on screen 'parking brake fault'. Car was turned off, restarted and lights went off. UIt then happened again later on when sat idle in the car park, but this time all the lights aforementioned, plus three statements- parking brake fauly, esp fauly, abs fault. These 3 faults are now showing in the fault log, all lights went back off again. Parking brake is one of those semi automatic ones up on the dash and still working. Only difference we can notice is that the hill start assist function appears not to work as well as it did before. Anyone had these issues? or does anyone know what's happened?
Thanks.

#2 Izzy

Izzy

    16 LX Newbie

  • Members
  • Pip
  • 1 posts

Posted 18 August 2012 - 12:18 PM

I've never been on the site before so please excuse the lack of jargon etc. We have a 58 plate c4 grand picasso and it's been great until this morning when the service light lit up at the roundabout, followed by the esp light and the abs light, and a notice on screen 'parking brake fault'. Car was turned off, restarted and lights went off. UIt then happened again later on when sat idle in the car park, but this time all the lights aforementioned, plus three statements- parking brake fauly, esp fauly, abs fault. These 3 faults are now showing in the fault log, all lights went back off again. Parking brake is one of those semi automatic ones up on the dash and still working. Only difference we can notice is that the hill start assist function appears not to work as well as it did before. Anyone had these issues? or does anyone know what's happened?
Thanks.


No anwers - just had the same problem! Did you get it sorted out?

#3 adrian1

adrian1

    16 LX Newbie

  • Members
  • Pip
  • 3 posts

Posted 21 February 2013 - 04:56 PM

Hi all my c4 grande has developed exactly the same warning lights and faults as above, could it be due to rainwater puddles and getting moisture in the sensors? I've read some where that there was a recall for c4 andc5 by Citroen around 2008/9. Can anyone here help out. ATB Adrian

#4 Teeny

Teeny

    16 LX Newbie

  • Members
  • Pip
  • 1 posts

Posted 06 March 2013 - 11:12 AM

Hi, my Grand Picasso has come up with the same warning lights. We managed to get some software onto our laptop and diagnose the fault which said it was the right front ABS sensor that was faulty. So we changed that and it still came up with the fault, so we then changed the wheel bearing and guess what it is still coming up with the same fault! Can anybody help with this problem. The only thing we can think of is (stabing in the dark realy) when it says right hand side does that mean right hand side when you are sitting in the car or when you are standing infront? Any help would be grateful as we are coming to the end of our tether with it.



#5 adrian1

adrian1

    16 LX Newbie

  • Members
  • Pip
  • 3 posts

Posted 06 March 2013 - 11:25 AM

Hi Teeny taking my motor to Telfords Citroen garage tomorrow with same problem will let you know on here how I get on. Will probably cost an arm and leg but got to do it . ATB Adrian

#6 adrian1

adrian1

    16 LX Newbie

  • Members
  • Pip
  • 3 posts

Posted 08 March 2013 - 09:51 AM

£3200 for new main wiring loom and abs includes labour at £60 an hour, feeling sick.