Jump to content


Photo

Knocking Noise From Suspension/drive Shaft?


  • Please log in to reply
17 replies to this topic

#1 homer

homer

    18 HDI LX

  • Members
  • PipPip
  • 72 posts
  • Location:Bristol

Posted 19 March 2005 - 10:08 PM

Hi,

Worryingly (I've only got three months of warranty left), my 02 2.0HDi Pic seems to have developed a noise. There is a "knocking noise" - seems to come from under the front passenger footwell when turning and going into a dip - but not all of the time.

SWMBO has heard this noise several times now - I'm puzzled as most of the time the car behaves normally and a visual inspection (by me) hasn't revealed anything.

If the car was older, I'd suspect drive shaft or damper problems - but I've only done 25,000 and it is not yet three years old.

Any thoughts? I'd take it straight to the dealers but sod's law says it won't happen when they have it!

#2 JoeBlunt

JoeBlunt

    ✩1.6 Hdi Desire 2 16v ✩

  • Admin
  • PipPipPipPipPip
  • 11018 posts
  • Gender:Male
  • Location:✩Kent, UK ☂
  • Interests:Digital Photography (Wish I had more time to learn all the tricks), Home Computing, Family stuff really i.e. eating out, holidays abroad, etc.........

Posted 19 March 2005 - 10:43 PM

I used to be cheeky (Having a Number plate with no year indicator) I'd take my Pic into Kwik fit and ask em to check it out, when they found the fault I'd say I'll be back in a week then take it straight to the dealer under warranty. :det:

Sounds like a warranty job but - approaching the 3yr mark & 25k I reckon the dealer may put it down to wear'n'tear, one things for sure it ain't gonna get better so do something sooner rather than later.................... :det:

Had my lower ball joints changed at 20,973mls :det:

Attached Files


2010 (10) Peugeot 207 1.4 Hdi Grey 5dr
2011 (61) Peugeot 207 1.4 Hdi Black 5dr
joeblunt@hotmail.com

#3 Boa

Boa

    HDi Exc. Arctic Steel

  • Members
  • PipPipPipPip
  • 427 posts

Posted 21 March 2005 - 08:25 PM

My one developed this less than a year old and <15k on the clock. Dodgy lower suspension ball joint (or something like that). It was replaced while I waited.
Boa
The Force is strong in this one
Lube Skystalker

#4 homer

homer

    18 HDI LX

  • Members
  • PipPip
  • 72 posts
  • Location:Bristol

Posted 24 March 2005 - 01:46 PM

Thanks for the replies. I'm booked in for 4th April - I'll let you know how I got on :huh:

#5 berlingo

berlingo

    16 LX Newbie

  • Members
  • Pip
  • 3 posts

Posted 06 April 2005 - 10:09 PM

could be the anti rollbar there is a link between the suspension leg and the anti roll bar my dealer replaced this link and the noise disappeared :rolleyes:

#6 Noddy

Noddy

    16 LX Newbie

  • Members
  • Pip
  • 19 posts

Posted 08 April 2005 - 03:11 PM

I had the same symptoms on mine at about a year old - dealer changed the anti-roll bar under warranty - noise went away. :D

#7 freddieloh

freddieloh

    16 LX Newbie

  • Members
  • Pip
  • 14 posts

Posted 09 April 2005 - 08:54 PM

My pic ( 1 yr old 1.6 HDi) developed a (probably similar) single "knocking noise" after about the first 3 months - seems to happen as the car goes onto a sloping drive way (with lowered kerb) or on turning. Dealer could not find fault at the first service last month. I have decided to wait until second service unless it becomes a bigger problem or if any of you out there suggests something more serious.

FL

#8 homer

homer

    18 HDI LX

  • Members
  • PipPip
  • 72 posts
  • Location:Bristol

Posted 12 April 2005 - 07:09 PM

Thanks for the advice everybody. My problem was the lower suspension ball joint - and happily for me my dealer replaced under warranty - no question about wear and tear - as long as under 3 yrs/60K miles no probs.

Cheers Guys :D

#9 whatsinaname

whatsinaname

    2.0 Hdi Exclusive Silver

  • Members
  • PipPipPipPipPip
  • 4646 posts
  • Gender:Male
  • Location:Derbyshire
  • Interests:fishing, motorbikes, garden, my dog

Posted 12 April 2005 - 07:15 PM

Hi,

Worryingly (I've only got three months of warranty left), my 02 2.0HDi Pic seems to have developed a noise. There is a "knocking noise" - seems to come from under the front passenger footwell when turning and going into a dip - but not all of the time.

SWMBO has heard this noise several times now - I'm puzzled as most of the time the car behaves normally and a visual inspection (by me) hasn't revealed anything.

If the car was older, I'd suspect drive shaft or damper problems - but I've only done 25,000 and it is not yet three years old.

Any thoughts? I'd take it straight to the dealers but sod's law says it won't happen when they have it!

i am getting the same knocking sound when turning its not the drive shaft and it doesnt do all the while 50 thou on clock

#10 CitPic

CitPic

    16 LX Newbie

  • Members
  • Pip
  • 2 posts

Posted 11 April 2007 - 07:12 PM

I had a front spring break a couple of weeks ago. My local garage replaced it but after 10 days or so the same creaking /knocking started. Took the car back and they tightened the nut on the link between the anti-roll bar and suspension strut. Mechanic said that my car wasn't the first to come back for the nut to be tightened after work has taken place. Noise has gone for now but he warned that if it started again that the link might need replacing.
2001 1.8 SX petrol

#11 RichardBaker

RichardBaker

    16 LX Newbie

  • Trainee Members
  • Pip
  • 2 posts

Posted 28 July 2011 - 09:54 AM

Hi first time posting on here....i have recently bought (july 11)a 52 plate picasso exclusive which did knock on the test drive but i was sure it was drop links...as i'm lucky to have a proper sized garage and a industral air compressor and tools decided it was worth a chance...how tricky could it possible be to find thia light 'chattering' noise over most rd surfaces??!!worked on my own cars for yrs with a spell in a garage as well... Right well very actually!!!, in order and bear in mind doing it myself and buying parts at trade otherwise this would have been crazy i've done both drop links, both complete bottom arms, anti roll arm bar bushes, strut top bearings, and finally n.s wheel bearing. It's been on the mot ramp with a friend and poked and prodded but still nothing can be found but everyone can hear the noise!!! my own thoughts now are engine mounts although rocking it around stationary does'nt produce any noise..or ware in the actual hub where the wheel bearing fits? getting annoyed now as its spoiling an otherwise nice car bought at very sensible mileage 80000 fsh and sensible money. And so far £170 of parts chucked at it, although not wasted if i keep it long term as i should get turn the key and do nothing for some time with everthing new!! Anybody got any thoughts on what to do next? the springs by the way were obvisously newish and the noise appears to come from the left passenger side, a light to medium chattering over even fairly smooth road surfaces. Thanks Richard ;)

#12 mcdig

mcdig

    Med Blue HDI owners club

  • Moderator
  • PipPipPipPipPip
  • 3820 posts
  • Gender:Male
  • Location:In a field, Nr Wigan

Posted 28 July 2011 - 10:47 AM

Is the undertray still on, if so are all the fixings and mountings on properly.

Some people are like slinkies - not really good for anything but they bring a smile to your face when you push them down the stairs!


#13 RichardBaker

RichardBaker

    16 LX Newbie

  • Trainee Members
  • Pip
  • 2 posts

Posted 28 July 2011 - 02:26 PM

Is the undertray still on, if so are all the fixings and mountings on properly.

hi the under tray is long gone and the sides have been checked and double checked and tie wrapped to wheel arch liners...good thinking though and pound to a penny it'll be something stupid like that in the end but i'm leaning towards an engine mount, or perhaps play in the hub itself etc...got a track rod end to replace this pm as this bar engine mounts is the last bit that could ware bar big things that should'nt i.e steering rack etc to replace. Dont think it'll be this as i can't'feel'any play but for £7 it's worth changing!! it's doing my head in..forgot to mention wheels have been balanced as well which was a job and half cos with no center caps on the alloys of a exclusive model it's a ten pound a side special wheel balance machine. ;~)

#14 ajrm

ajrm

    16 LX Member

  • Members
  • Pip
  • 44 posts
  • Gender:Male
  • Location:Whitstable, Kent

Posted 28 July 2011 - 05:56 PM

I had a light clattering over slightly uneven surfaces on my 03 Excl. The recent MOT had an advisory that the n/s track rod end was showing slight signs of wear. I just replaced it, noise gone! Could be what yours is.
Allasn

#15 keefie

keefie

    16 LX Newbie

  • Members
  • Pip
  • 7 posts

Posted 01 August 2011 - 11:13 PM

I just bought a x-plate picasso and it is very nice apart from one odd noise.

On taking up drive there is a clonk from somewhere underneath. This doesn't happen again until either applying the brakes or coming down a hill on overrun. Then it will happen again when starting to accelerate again. Each time it is just one clonk.

There dont seem to be any other associated noises, cornering doesnt seem to make a difference.

#16 stimulator

stimulator

    1.6 Cherry Red Metallic, wonder car

  • Members
  • PipPipPipPipPip
  • 7683 posts
  • Gender:Male
  • Location:Waterlooville Hants
  • Interests:Model trains OO gauge. C3 Picasso, Grandchildren

Posted 02 August 2011 - 07:59 AM

Rear engine mount early pics suffered.
62 Reg C3 Picasso VTR+ 1.6 HDi 92BHP
Previous Xsara Picasso 20HDi, C3 SX 1.4HDi, C3 SX 1.6HDI, C4 Picasso 1.6HDi VTR+ EGS

#17 keefie

keefie

    16 LX Newbie

  • Members
  • Pip
  • 7 posts

Posted 02 August 2011 - 09:11 PM

Rear engine mount early pics suffered.

I googled to get a picture of one and... i remember changing one on one of my 205s, looks like they are exactly the same! Not expensive either. Great!

Thanks for the tip.

#18 thebiglad

thebiglad

    16 LX Member

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:Central France
  • Interests:Land Rovers and travelling.

Posted 04 August 2011 - 07:27 PM

I had this on the 2003 Pic that I bought recently. It turned out to be the left hand lower suspension arm and the right hand track rod end.

After replacement the car feels like a new 'un again. Very Happy Bunny.