Jump to content


Photo

Glow plugs 1.6 hdi


  • Please log in to reply
4 replies to this topic

#1 Plonk

Plonk

    16 LX Newbie

  • Members
  • Pip
  • 14 posts

Posted 30 April 2019 - 02:30 PM

Hi,
Does anyone have a wiring diagram for the glow plug circuit on a 2005 1.6 hdi desire.?
Mine has the solid state relay and from what I can gather with these relays (aluminium heat sink type each glow plug is fed separately from the relay . The problem is when testing for resistance at relay plug to glow plug connections I can not get a resistance reading ). So I either have 4 duff glow plugs ( it has always started o.k) or the relay information I have found is wrong. My reason for checking the plugs is the EML light coming on quite regularly lately with the P1351 error code. I was hoping to find a faulty relay (it still might be) but it looks as though the glow plugs could be the culprit and they look like a pig to do.
A glow plug/ relay diagram would be a massive help.I realise I can check fthe resistance readings directly on the glow plus but had a quick look and they don’ look very accessible. I have a Haynes manual but can’t seem to find a diagram for this circuit.
Thanks
Paul

#2 gray

gray

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 1,471 posts
  • Gender:Male

Posted 01 May 2019 - 07:14 AM

The search on here seems knackered, but I remember seeing something like this a while ago.....

 

Good old Google  :)

http://www.citroenpi...w-plug-relay/ 



#3 Plonk

Plonk

    16 LX Newbie

  • Members
  • Pip
  • 14 posts

Posted 01 May 2019 - 11:20 AM

Hi gray, yes I had already seen this and that is the information I was going on. I just wanted a Citroen diagram to make sure I was not barking up the wrong tree. If the above information is correct all 4 of my glow plugs are knackered. I just hope I can get them out without snapping them (which seems to be quite common on these). I have the Servicebox DvD's but can't get it to run on my 64 bit PC.



#4 Plonk

Plonk

    16 LX Newbie

  • Members
  • Pip
  • 14 posts

Posted 18 June 2019 - 05:59 PM

Further to my above post the P1351 error code has been coming on regularly resulting in the EML coming on accompanied by. The engine cutting out momentarily. I decided to bite the bullet and ordered a new relay and a set of glow plugs. Unfortunately the relay made no difference so I stripped out the air filter assembly to install the new glow plugs. When I finally got to see(feel) the glow plugs I found the old plugs have a terminal held on by a nut whereas the new ones are a push on type si Iended up putting it all back together.
As stated all glow plugs are duff but the car starts fine but my wife won’t drive the car any distance with the fault present. I am going to re order the correct glow plugs but from my look today only two ( N/s ) look reasonably easy to get at, no 3 looks possible but I couldn’t even feel where no.4 was!?
I am just wondering if anyone has replaced all 4 glow plugs and can give any tips on gaining access or if anyone knows why duff glowplus would cause the engine to cut out.
Thanks
paul

#5 Plonk

Plonk

    16 LX Newbie

  • Members
  • Pip
  • 14 posts

Posted 28 June 2019 - 02:08 PM

Right, I am in need of some help if there are any Citoen mechanics about. After repeatedly getting the P1351 fault which then progressed to the engine light coming on and sudden loss of power I changed the glowplug relay but it made no difference I then

found all glowplugs were duff so bit the bullet and changed them (never again). Took it out for a drive and within yards the EML light came on again wth loss of power. The strange thing is if I unplug the glowplug relay then start it up the fault remains but when I switch it off and re plug the reay and restart it the fault dissappears( until the next time). Has anyone any ideas before I set light to it?