Jump to content


Photo

2015 C3 Picasso BlueTooth


  • Please log in to reply
2 replies to this topic

#1 Budd

Budd

    16 LX Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Crawley West Sussex

Posted 14 January 2019 - 04:09 PM

Hi all, any ideas? I have a 2015 C3 Picasso and my Bluetooth has been working fine, until now. My phone and the Mrs phone (both Iphone's with the latest software IOS 12.1.2 update) used to connect automatically once the ignition was turned on. This is now not the case, I have to go through the procedure of pairing the phones with the codes etc every time and that's if the car picks up the phones in the first place. Also, before this problem I used to be able to hear my text messages, not the end of the world of course but this to has stopped working. Has anyone experienced this before and has a fix?

Thank you



#2 stimulator

stimulator

    1.6 Cherry Red Metallic, wonder car

  • Members
  • PipPipPipPipPip
  • 9,548 posts
  • Gender:Male
  • Location:Waterlooville Hants
  • Interests:Model trains OO gauge. C3 Picasso, Grandchildren

Posted 14 January 2019 - 06:43 PM

I think there is an ability on the system for you to tell it to forget the connection. Try that and get your phone to forget too. Now try a new pairing. Worth a try.
  • Budd likes this
17 Reg C3 Saloon Flair 1.2 110BHP
Previous Xsara Picasso 20HDi, C3 SX 1.4HDi, C3 SX 1.6HDI, C4 Picasso 1.6HDi VTR+ EGS 62 Reg C3 Picasso VTR+ 1.6 HDi 92BHP

#3 Budd

Budd

    16 LX Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Crawley West Sussex

Posted 14 January 2019 - 08:13 PM

Hi, thank you for your info, its worth a try, I have tried the forgetting idea, car and phone and this has not changed the fault. I have just also read about a very similar fault on the ICE forum, it mentioned a replacement stereo and a Citroen plug in under warranty, unfortunately mines now out of its warranty. Maybe its time to fit a non standard Bluetooth stereo but I don't want to loose the reverse sensor audio warning, could this be a possible option??