Jump to content


Photo

Engine Fault light


  • Please log in to reply
4 replies to this topic

#1 Picobus

Picobus

    16 LX Newbie

  • Members
  • Pip
  • 11 posts

Posted 01 November 2018 - 12:18 PM

I have a Citroen Xsara Picasso 1.6 HDi (2006), which I have had since new.  It has done around 70,000 miles.  Yesterday morning, when I started it, the Engine Fault light stayed on, and there was an "Engine Fault" text comment on the dashboard, with a "beep beep" audio warning.  It was the same the two next times I started it, but the next time, the light went out when the car was started.  Each time the light came on, it stayed on till the car was switched off.  I was in a 30MPH speed limit, so I didn't have much opportunity to see if it was performing normally, but everything seemed OK - I didn't notice any difference at all. 

The light did not come on while the car was in use - it happened instantly on starting the engine, so I thought it would be unlikely to be due to sensing a bad mixture, as that would take a second or two (I'm surmising here - if I knew the answer, I wouldn't be asking the question)

Does this herald problems in my near future?  Has anybody had, and solved this 'symptom' (it's not actually a problem yet)?


Edited by Picobus, 01 November 2018 - 12:20 PM.


#2 discv

discv

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 900 posts
  • Gender:Male
  • Location:London UK

Posted 01 November 2018 - 01:57 PM

You'll need to get a fault code reader on this one. even if the MIL light has gone out, the fault/s will show up as 'historic'.

For a quick look see I use a Launch CreaderV+ but cheaper/simpler readers can be had.

 

https://www.ebay.co....bA430:rk:3:pf:0


C4 Grand Picasso 1.6 HDi 16V FAP/DPFS 110, -Auto (DV6 - 80kW) (C4) (DT) (2008)

 


#3 gray

gray

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 1,444 posts
  • Gender:Male

Posted 04 November 2018 - 08:12 PM

As Disc says, try to get any old codes read. It could be anything.. mine was EGR.

#4 Picobus

Picobus

    16 LX Newbie

  • Members
  • Pip
  • 11 posts

Posted 09 November 2018 - 12:46 AM

OK, thanks gents.  I have a cheapo code reader somewhere, so I'll dig it out and see if it's good enough to find something.  Last time I tried to use it, it gave me some codes, but didn't find my problem.

BTW, since the incidents mentioned, the light hasn't been on again.



#5 Ozzie

Ozzie

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 406 posts
  • Gender:Male
  • Location:Somerset

Posted 10 November 2018 - 08:40 AM

last week I was toddling along at 30 in the 2.0 Hdi  , beep beep  ENGINE FAULT ,

 

the car almost ground to a halt but I continued slowly to a layby.

 

I didn't switch off, in case it wouldn't restart , but left it ticking over for a while then pulled away and the car performance was back to normal.

 

The ENGINE FAULT and beeps came back on for the next 6 starts but then cleared itself.

 

Couldn't get the code as it's a 2003 diesel which needs Lexia but it does make me think that  certain fault codes do clear themselves , others don't.

 

The car has been ok since but I had to do something , so changed the fuel filter , maybe a bit of water / condensation  in the fuel.