Jump to content


Photo

sensors on rear brakes, speed or abs? fault finding for mot


  • Please log in to reply
1 reply to this topic

#1 Tim-Dieselx

Tim-Dieselx

    18 HDI LX

  • Members
  • PipPip
  • 62 posts

Posted 07 October 2018 - 12:30 AM

been wondering if the sensors on my 07 xsara picasso 1.6 turbo diesel are speed sensors or abs sensors?

there is a solid magnetic ring no indents like the front. and even thought they look like the mark 2 sensors ( no metal bit sticking out) that are on the front im not sure they are the same.

 

story goes, 3 months ago car failed mot on a few bit including abs non fault,

been slowly replacing all the parts that were duff ( as im ill with multiple conditions which limit my ability to now work constantly).

New Turbo,

MAF sensor,

2 front ABS sensors,

Both front drop links,

Both front Track Rod Ends,

Both back drum Brakes,

Both Back Brake Calipers,

Hand Brake Uneven,

Rear Brake Lights

Front Indicator ect.

Sill welding on both sides ( common problem with these ).

and a broken seat-belt.

 

replacing so meny bolts that sheered off or snapped and re-doing brake lines that i broke lol.

car starts fine,  no faults on obd2 ( though 2 pending )

but a second after it starts even before you move the car it shows up " ABS, Non Fault" and stays there

If i drive sometimes the speed readout had been showing a slower speed than im actually driving GRRR

 

checked and replaced both front abs sensors

checked & cleaned both front abs rings

Cleaned both rear sensors and the rear has no staggered ring just a solid band. ( which i wondered if it was a speed sensor?)

reset ECU after clearing fault codes ( none anyway but just in case) and by that i mean take off the battery for a few hours.

abs non fault instantly shows up.

 

So im at a bit of a loss.

tempted to remove the rear sensors and check them for continuity with a amp meter. 

 

any other suggestions? and anyone know what the rear sensors are as the haynes manual is a bit weird.

 

 

 


  • DwaynecymN likes this

#2 Tim-Dieselx

Tim-Dieselx

    18 HDI LX

  • Members
  • PipPip
  • 62 posts

Posted 11 October 2018 - 12:20 AM

found another haynes manual for 07 + apparantly they are abs sensors for the 2 rear ones. i tried to attach a multi-meter to 1 and spin the wheel and nothing. so will try the other side one tomorrow.

will have to adjust the hand brake tomorow as its tripping the warning sensor after the new brakes were on.

 then hopefully i can get it moted