Jump to content


Photo

Towbar Relay Electrics Problems


  • Please log in to reply
6 replies to this topic

#1 gazuk2015

gazuk2015

    16 LX Newbie

  • Members
  • Pip
  • 15 posts

Posted 15 June 2018 - 09:38 PM

Hi,

 

I recently fitted a towbar to my Picasso. With doing some research on here , i fitted a 7 way relay to the car, i believe i have connected all the wires correctly.

 

But i can only seem to get the right indicators to work on my caravan. When the lights are put on, the indicator buzzer is constantly on. and if the left indicator is a solid light (rather than flashing).

 

Can i confirm whether on the Picasso whether the brake and lights are separate bulbs? so require different feeds from the relay .

 

Can anybody understand, what may be going on? 

 

Thanks for your time in advance

 

Gaz



#2 stimulator

stimulator

    1.6 Cherry Red Metallic, wonder car

  • Members
  • PipPipPipPipPip
  • 9,532 posts
  • Gender:Male
  • Location:Waterlooville Hants
  • Interests:Model trains OO gauge. C3 Picasso, Grandchildren

Posted 15 June 2018 - 11:34 PM

Ok in the tech section MK1 & 2 in the FAQs you will find my notes that I wrote when I fitted a tow bar to my MK1 Xsara Picasso. I will confirm later today but I recall that the stop and tail lights are in one bulb. Irrespective of that they are separate filament and thus there are two input wires. I assume that if you put the relay in the left of the boot that you ran a separate lead across from the right light across to it. You only need to do that for the indicator. Will check the notes later.
17 Reg C3 Saloon Flair 1.2 110BHP
Previous Xsara Picasso 20HDi, C3 SX 1.4HDi, C3 SX 1.6HDI, C4 Picasso 1.6HDi VTR+ EGS 62 Reg C3 Picasso VTR+ 1.6 HDi 92BHP

#3 gazuk2015

gazuk2015

    16 LX Newbie

  • Members
  • Pip
  • 15 posts

Posted 16 June 2018 - 06:49 AM

Yes, I have ran a wire across to the right indicator. Right indicator is working fine.

I believe I have the black / brown going to tail lights and a separate cable to the brake light.

Missus has car today, so trying to remember !! Lol

#4 stimulator

stimulator

    1.6 Cherry Red Metallic, wonder car

  • Members
  • PipPipPipPipPip
  • 9,532 posts
  • Gender:Male
  • Location:Waterlooville Hants
  • Interests:Model trains OO gauge. C3 Picasso, Grandchildren

Posted 16 June 2018 - 09:36 AM

Notes are here http://www.citroenpi...846-faqs/page-3 scroll down to #54.

 

The notes that came with my 6 way relay are annotated .

 

Wires from relay

Yellow goes to Passenger side indicator

Blue goes to Fog light

Green goes to Drivers side indicator

Brown goes to right hand tail light

Red goes to brake light

Black goes to right hand tail light

WHITE is earth.

 

 

 

mine HAD two POWER LEADS BOTH OF WHICH HAVE TO BE CONNECTED as the relay unit is split into two separate section inside.

 

Check that you have the right colour wires going to the correct relay unit colours. You will have to check the car wires as CITROEN change loom colours like we change underwear. . Make sure that the indicators go to the correct wire on the unit. The buzzer is driven by the output of the indicator relays. The indicators on the caravan should be on pins  1 & 4 .

 

Pin 1 is left ind tow bar plug colour YELLOW

Pin 2 is Fog light tow bar colour BLUE

PIN 3 is EARTH

Pin 4 right ind GREEN 

Pin 5 Rt side lt BROWN

Pin 6 Brake light RED

Pin 7 Lft side lt BLACK.

 

CHECK you have a good earth or the volts will find a way back via another circuit.

 

 

 

 


17 Reg C3 Saloon Flair 1.2 110BHP
Previous Xsara Picasso 20HDi, C3 SX 1.4HDi, C3 SX 1.6HDI, C4 Picasso 1.6HDi VTR+ EGS 62 Reg C3 Picasso VTR+ 1.6 HDi 92BHP

#5 gazuk2015

gazuk2015

    16 LX Newbie

  • Members
  • Pip
  • 15 posts

Posted 16 June 2018 - 12:44 PM

Thanks for reply.

 

I have found a copy of my instructions online @ http://wizardimports...g-instructions/

 

I need to look at the car now to see if anything is wrong....will reply with details...

 

thanks



#6 gazuk2015

gazuk2015

    16 LX Newbie

  • Members
  • Pip
  • 15 posts

Posted 28 July 2018 - 06:38 PM

How finally got around to having another go at the electrics . I found that i had connected the left indicator to the rear light/ brake by mistake, because there were two wires going into the connector for the rear light/brake, so i thought that the left of the two wires was the indicators. 

 

Thanks for the help



#7 stimulator

stimulator

    1.6 Cherry Red Metallic, wonder car

  • Members
  • PipPipPipPipPip
  • 9,532 posts
  • Gender:Male
  • Location:Waterlooville Hants
  • Interests:Model trains OO gauge. C3 Picasso, Grandchildren

Posted 29 July 2018 - 08:23 AM

Glad it's sorted
Stim
17 Reg C3 Saloon Flair 1.2 110BHP
Previous Xsara Picasso 20HDi, C3 SX 1.4HDi, C3 SX 1.6HDI, C4 Picasso 1.6HDi VTR+ EGS 62 Reg C3 Picasso VTR+ 1.6 HDi 92BHP