Jump to content


Photo

Fitting a small subwoofer in my 09 C4 Picasso - Help needed.


  • Please log in to reply
2 replies to this topic

#1 Davekgtrf

Davekgtrf

    16 LX Newbie

  • Members
  • Pip
  • 8 posts

Posted 11 June 2018 - 03:01 PM

After getting some (possibly bad) advice I purchased a Pioneer TS-WX130DA active subwoofer, the type that's designed to go under a seat or somewhere with not much space.

I was told that it's as easy as fitting a hardwired dash cam, which I've already done so I thought I'd be fine.

Has anyone here fitted one of these or something similar?

Basically the connection to the radio is fine, no problems there as I recently had a Pioneer head unit fitted with subwoofer output.

It's the power bit that I'm not so sure about.

Can someone help me out?

#2 Davekgtrf

Davekgtrf

    16 LX Newbie

  • Members
  • Pip
  • 8 posts

Posted 11 June 2018 - 04:20 PM

I've figured that I need an always on terminal but I can't determine which terminal in the fuse box (glove box one) I could use.

There is also three wires on the power cable that comes with the subwoofer. Yellow, black and blue.

The yellow is for power, the black is ground but nowhere in the ridiculous Pioneer manual I have does it say what the blue cable is for.

#3 Davekgtrf

Davekgtrf

    16 LX Newbie

  • Members
  • Pip
  • 8 posts

Posted 11 June 2018 - 04:29 PM

Apologies as I think I posted this in the wrong forum. I've reposted it in the entertainment section but can't find a way to delete this thread.

Could an admin please remove it for me?