Jump to content


Photo

Engine fault light


  • Please log in to reply
28 replies to this topic

#1 carisma

carisma

    16 LX Newbie

  • Members
  • Pip
  • 12 posts

Posted 13 February 2018 - 04:40 PM

Hi

I have a 2006 xsara picasso 1.6 petrol desire, the engine fault light came on yesterday and remains on. I have a Maxiscan ms309 which I plugged to see what the fault was, it detects there is a fault but when I try and read code it says there is no fault stored ????? Can anyone help please. forgot to say car starts and runs fine.



#2 gray

gray

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 1,433 posts
  • Gender:Male

Posted 13 February 2018 - 08:01 PM

Try a different code reader ?   I've got a basic one (U480) that seems to do job for me...   whereabouts are you ?  :)

Maybe it needs Lexia to drill down further ?


Edited by gray, 13 February 2018 - 08:01 PM.


#3 carisma

carisma

    16 LX Newbie

  • Members
  • Pip
  • 12 posts

Posted 14 February 2018 - 01:48 AM

Hi Gray
Cheers for the reply. Im up in Northumberland, I haven't got another code reader, will have to ask about see if anyone I know has one. Excuse my ignorance but what is Lexia ??????

#4 gray

gray

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 1,433 posts
  • Gender:Male

Posted 14 February 2018 - 08:02 AM

I used to live up there too (Longhoughton ! :) ) way down South now though .. If you find a kindly garage, they may do it for free for you...

Lexia is the software that garages use to do fault finding and configuration. You can now buy it for home use too, but it can be complicated to set-up and use. Usually Chinese clone software, that need a Win XP laptop.

http://www.citroenpi.../22681-lexia-3/

Edited by gray, 14 February 2018 - 08:02 AM.


#5 carisma

carisma

    16 LX Newbie

  • Members
  • Pip
  • 12 posts

Posted 14 February 2018 - 02:10 PM

Ah man, that would have been handy, will just have try and track down another one. That Lexia seems a bit too deep for me.Cheers for the info ????

#6 hunter.england

hunter.england

    16 LX Newbie

  • Members
  • Pip
  • 19 posts

Posted 14 February 2018 - 03:23 PM

Hi, i have one of the cheap bluetooth/wifi readers that connects to a phone. No idea if it is any better but there might be more info on the phone app that you are getting your reader?

 

https://www.amazon.c...e?ie=UTF8&psc=1



#7 discv

discv

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 878 posts
  • Gender:Male
  • Location:London UK

Posted 14 February 2018 - 04:32 PM

OP- I wonder what happens if you use the scanner you have got to clear any fault codes and extinguish the MIL lamp. Sometimes the faults go 'historic' which means the fault did not come up again. An example of this can be if you run out of petrol etc.


C4 Grand Picasso 1.6 HDi 16V FAP/DPFS 110, -Auto (DV6 - 80kW) (C4) (DT) (2008)

 


#8 carisma

carisma

    16 LX Newbie

  • Members
  • Pip
  • 12 posts

Posted 14 February 2018 - 06:40 PM

Hi discv
I have tried erasing the fault but because it doesn't see it, it doesn't do anthing, and says something like code erase fail turn off and switch back on !!!!!! ????

Edited by carisma, 14 February 2018 - 06:42 PM.


#9 jerryb

jerryb

    16 LX Member

  • Members
  • Pip
  • 22 posts

Posted 14 February 2018 - 08:07 PM

Just read this, I'm getting an engine fault light that comes back if I clear it with my cheapo reader, there are three beeps when it comes on, I took it to a garage but they said their reader was not giving them an answer? Anyone out there got any ideas?

#10 gray

gray

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 1,433 posts
  • Gender:Male

Posted 15 February 2018 - 08:13 AM

 

Just read this, I'm getting an engine fault light that comes back if I clear it with my cheapo reader, there are three beeps when it comes on, I took it to a garage but they said their reader was not giving them an answer? Anyone out there got any ideas?


Do you get any messages on the dash as it beeps ? Maybe a BSI reset will help (always seems to be the first thing to try if these cars go 'wonky') :)

#11 carisma

carisma

    16 LX Newbie

  • Members
  • Pip
  • 12 posts

Posted 15 February 2018 - 12:00 PM

Hi
What is a BSI reset and hiw do you do one. Mines just says "Engine Fault" ????

#12 carisma

carisma

    16 LX Newbie

  • Members
  • Pip
  • 12 posts

Posted 15 February 2018 - 04:56 PM

Tried again with my maxiscan Ms309, it came uo with the code P0139 - O2 sensor circuit slow response Bank 1 sensor 2. It wont let me clear it. Is this the sensor after the cat?? Any recommendations for a new one ??

Edited by carisma, 15 February 2018 - 04:59 PM.


#13 gittos

gittos

    1.6 Blue HDi EAT6

  • Members
  • PipPipPipPip
  • 1,028 posts
  • Gender:Male
  • Location:Bolton, Lancashire

Posted 15 February 2018 - 07:21 PM

O2 sensor (Lambda Sensor) is uaually located in the exhaust pipe or exhaust manifold when it has terminated to a single pipe (before the Cat), there may also be one after the Cat. On your car it is located protruding from the silver metal heat shield on the front of the engine, looks a bit like a spark plug with a wire coming from it.

 

Tried to upload a photo but the site won't let me

 

This will give you a good idea of how its done https://www.youtube....h?v=NBsrwyGnJgU

 

 


Edited by gittos, 15 February 2018 - 07:22 PM.

  • Was - 2002 1.6 Petrol Picasso SX     Then -2009 C4 Picasso VTR+ 1.6 VTI Petrol   Then- 2015 C4 Picasso 1.6 Blue HDi EAT6 Exclusive   Now..2018 C4 Picasso 1.2 PureTech Feel EAT6

#14 gray

gray

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 1,433 posts
  • Gender:Male

Posted 15 February 2018 - 07:46 PM

O2 sensor (Lambda Sensor) is uaually located in the exhaust pipe or exhaust manifold when it has terminated to a single pipe (before the Cat), there may also be one after the Cat. On your car it is located protruding from the silver metal heat shield on the front of the engine, looks a bit like a spark plug with a wire coming from it.

 

Tried to upload a photo but the site won't let me

 

This will give you a good idea of how its done https://www.youtube....h?v=NBsrwyGnJgU

 

Hopefully this  one works then  :)

 

If it's this one, then   Check the wire is connected first  !

 

Edit: It's a Peugeot, but the same engine.

Attached Files


Edited by gray, 15 February 2018 - 07:46 PM.

  • gittos likes this

#15 carisma

carisma

    16 LX Newbie

  • Members
  • Pip
  • 12 posts

Posted 15 February 2018 - 09:13 PM

Hi Guys
Thanks for the info, not sure if its this one, according to code it says "Bank 1'sensor 2" my thoughts are because it is sensor 2 is this the one in the exhaust after the cat ?????

#16 rawthey

rawthey

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 405 posts
  • Gender:Male
  • Location:Cumbria

Posted 16 February 2018 - 09:37 AM

Thanks for the info, not sure if its this one, according to code it says "Bank 1'sensor 2" my thoughts are because it is sensor 2 is this the one in the exhaust after the cat ?????

 

According to https://www.youtube....h?v=cf6oOGiw5Qo it looks like your problem would be the the sensor after the cat.


Mike
Xsara Picasso (58) 1.6i 16V Desire, Iron Grey

#17 gray

gray

    1.8 HDI Exclusive

  • Members
  • PipPipPipPip
  • 1,433 posts
  • Gender:Male

Posted 16 February 2018 - 09:39 AM

 

Hi Guys
Thanks for the info, not sure if its this one, according to code it says "Bank 1'sensor 2" my thoughts are because it is sensor 2 is this the one in the exhaust after the cat ?????


That'd be my thinking too, after looking at it: http://o2sensors.com...n-and-locations
Same thing though - check the wire is on it first, before changing it.... :)

#18 jerryb

jerryb

    16 LX Member

  • Members
  • Pip
  • 22 posts

Posted 16 February 2018 - 10:20 AM

In reply to earlier post, just engine fault and three beeps.

#19 carisma

carisma

    16 LX Newbie

  • Members
  • Pip
  • 12 posts

Posted 16 February 2018 - 05:00 PM

Hi
Thanks for the info, I have bitten the bullet and irdered a new post cat sensor, should be hear tuesday, will let you now the the result
Cheers ????????
  • gray likes this

#20 carisma

carisma

    16 LX Newbie

  • Members
  • Pip
  • 12 posts

Posted 25 February 2018 - 02:40 PM

HI

Sorry for the delay. Fitted new sensor, fault light still on, tried to reset with Maxiscan, no luck, wiggled a few cables etc. still no luck!!!!!!

Left new sensor in and drove around for a couple of days contemplating my next move, Friday got in started up, no fault light ??????? Have started stopped drove about still no fault light. Happy bunny, not sure if you have to run it for a while with new sensor in or what, baffles me but sorted, fingers crossed :-)