Jump to content


Photo

Radio and Rear Wiper issues


  • Please log in to reply
4 replies to this topic

#1 Bornagainbiker

Bornagainbiker

    1.8 Desire (Petrol) 2004

  • Members
  • PipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:United Kingdom
  • Interests:Classic Cars, DIY mechanics, home computing

Posted 22 March 2014 - 08:06 AM

Hi All,

 

This is related to my ECU Woes thread: http://www.citroenpi...21740-ecu-woes/

 

ECU is back and car runs again, but I have two new issues - not sure if they are related:

 

1. Rear wiper no longer parks correctly (actually parks quite randomly) and exhibits odd behaviour - it started wiping when I unlocked the car, and when I was reversing.

2. Radio does not work. There's power to it, because it whirrs when you press the CD eject button.

 

Any ideas on this?

 

I'm going to take a look at the BSi - that has been removed and replaced, and although I was careful with marrying up the right connectors, I might not have put one in properly. There was also an unused socket on it - I couldn't remember if there was anything plugged in to it before, but I couldn't find a 'spare' connector that fitted it amongst the myriad of cables under there.

 

cheers,

 

Phillip


  • semisizaqor, GeorgeNax, JosephbuG and 14 others like this

Current vehicles: 2004 Citroën Picasso 1.8 Desire (owned since 2008), 2004 Ford Fiesta 1.2 Finesse (owned since 2009)
Previous vehicles (in approx reverse order of ownership): Ford Galaxy (2000 1.9TDi), Rover 200 (1999 1.1), Toyota Carina E (1993 1.6), Toyota Previa (1992 2.4), Peugeot 309 (1990 1.3), Renault 5 (1990 1.1), Austin Montego (1986 1.6), Fiat Tempra (1992 1.8), Renault 5 (1989 1.2), Lada Riva (1986 1.5), Vauxhall Cavalier SRi (1983 1.8), Lada 1200 Estate (1984 1.2) - what a lot of cars!
Also owned the following bikes (reverse order): Yamaha Radian YX600 (1986), Honda CD175 (c.1970s), Yamaha YB100 (c.1980s), Honda C50 (c. 1980s)


Should probably change my forum name as I sold the Radian a while ago! Currently get my thrills co-driving a friend's 914.


#2 stimulator

stimulator

    1.6 Cherry Red Metallic, wonder car

  • Members
  • PipPipPipPipPip
  • 9,604 posts
  • Gender:Male
  • Location:Waterlooville Hants
  • Interests:Model trains OO gauge. C3 Picasso, Grandchildren

Posted 22 March 2014 - 10:08 AM

Re wiper. The unit is parked by a switch mounted in the wiper unit. Possible it's stuck.

If you are reversing then the rear wiper can be set to wipe if fronts are armed.

 

Re radio.

If they have wiped the unit then the head may need to be re-introduced to the BSI using a LEXIA type terminal.  Have you got two live feeds to the head?


17 Reg C3 Saloon Flair 1.2 110BHP
Previous Xsara Picasso 20HDi, C3 SX 1.4HDi, C3 SX 1.6HDI, C4 Picasso 1.6HDi VTR+ EGS 62 Reg C3 Picasso VTR+ 1.6 HDi 92BHP

#3 Bornagainbiker

Bornagainbiker

    1.8 Desire (Petrol) 2004

  • Members
  • PipPipPipPip
  • 598 posts
  • Gender:Male
  • Location:United Kingdom
  • Interests:Classic Cars, DIY mechanics, home computing

Posted 22 March 2014 - 02:43 PM

It's all sorted now.

 

In addition to the two problems described above, the tailgate lock wasn't working.

 

The radio now works, the rear wiper doesn't have a mind of its own (it would run when you opened a door - even without the key in the ignition!), and I can get in the boot.

 

What I did to fix was to remove the BSi, check that I hadn't bent any pins or anything when I'd refitted it before, pulled all the fuses out, checked and cleaned them, then refitted BSi.

 

Even though all the connectors felt tight when I pulled them off, there must have been one that wasn't seated correctly.

 

So pleased to have a fully functioning car again! We managed as a one car family for about six weeks, partly because I could hire one when I needed to for work without much of a negative cost impact, and partly because I've not had to go anywhere on business for a couple of weeks.

 

Thanks to everyone for advice offered.


Current vehicles: 2004 Citroën Picasso 1.8 Desire (owned since 2008), 2004 Ford Fiesta 1.2 Finesse (owned since 2009)
Previous vehicles (in approx reverse order of ownership): Ford Galaxy (2000 1.9TDi), Rover 200 (1999 1.1), Toyota Carina E (1993 1.6), Toyota Previa (1992 2.4), Peugeot 309 (1990 1.3), Renault 5 (1990 1.1), Austin Montego (1986 1.6), Fiat Tempra (1992 1.8), Renault 5 (1989 1.2), Lada Riva (1986 1.5), Vauxhall Cavalier SRi (1983 1.8), Lada 1200 Estate (1984 1.2) - what a lot of cars!
Also owned the following bikes (reverse order): Yamaha Radian YX600 (1986), Honda CD175 (c.1970s), Yamaha YB100 (c.1980s), Honda C50 (c. 1980s)


Should probably change my forum name as I sold the Radian a while ago! Currently get my thrills co-driving a friend's 914.


#4 stimulator

stimulator

    1.6 Cherry Red Metallic, wonder car

  • Members
  • PipPipPipPipPip
  • 9,604 posts
  • Gender:Male
  • Location:Waterlooville Hants
  • Interests:Model trains OO gauge. C3 Picasso, Grandchildren

Posted 22 March 2014 - 02:54 PM

Well done keep it away from water.


17 Reg C3 Saloon Flair 1.2 110BHP
Previous Xsara Picasso 20HDi, C3 SX 1.4HDi, C3 SX 1.6HDI, C4 Picasso 1.6HDi VTR+ EGS 62 Reg C3 Picasso VTR+ 1.6 HDi 92BHP

#5 The Welshman

The Welshman

    18 HDI LX

  • Members
  • PipPip
  • 118 posts
  • Gender:Male
  • Location:Chesterfield Derbyshire UK
  • Interests:Camping, Gardening, Computers, and my Xsara Picasso.

Posted 22 March 2014 - 03:44 PM

Well done keep it away from water.

And Don't feed it after midnight   :lol:

Glad your sorted


2005 Citroen Picasso 2 ltr HDI    :ph34r: