Jump to content


Photo

Main Beam Light Problem Picasso 1.6

light problem main beam

  • Please log in to reply
6 replies to this topic

#1 kathemmi

kathemmi

    16 LX Newbie

  • Members
  • Pip
  • 7 posts

Posted 14 January 2013 - 08:05 PM

Here is the problem:

Side, Dip, Fogs & rear lights all working as they should, until main beam activated either flash or permanent. Then lights go out except for side lights & rear lights & fogs. The blue dash board main beam light comes on as normal.

A Citroen specialist said the problem was probably a faulty Comm Unit, quoted £230 + fitting & vat.

Before taking this action I replaced the fuses (the light fuses are in the engine compartment box, not the under dash box as it says in the hand book)  and bulbs and searched the internet for various "fixes" & "resets" all of which produced zero results. I cheched the wiring as far as I could for  breakages.

At this point I decided the dealer was probably correct & bought & fitted a new comm unit.

Guess what - no change - still the lights go out when main beam activated.

One thing I have noticed today is that when the engine & ignition is turned off the main beam lights will flash once only when the switch is used in flash mode. If the switch is used a second time only the blue dash board light comes on, not the main beam lights.

Can anyone help with this problem?

Thanks - a confused newbie

 

53 Reg 1.6 petrol Picasso


Edited by kathemmi, 14 January 2013 - 08:05 PM.

  • allonopluflab likes this

#2 chili1496

chili1496

    18 HDI LX

  • Members
  • PipPip
  • 63 posts
  • Gender:Male

Posted 15 January 2013 - 01:46 PM

i have just had my xsar pic for 1 week it is a 2003 1.6i sx model, i read your post last night and been one of the unlucky peeps that starts work at 4am i rememberd you :) and tried my lights. i was driving at the time so with side lights and dipped beam on off i set to work i got to a nice dark stretch of road and hit main beam and it also looked like my dipped beams went out  while main was on and when i switched back to dipped beam all was back to normal.

 

so maybe its not a fault?



#3 stimulator

stimulator

    1.6 Cherry Red Metallic, wonder car

  • Members
  • PipPipPipPipPip
  • 9,600 posts
  • Gender:Male
  • Location:Waterlooville Hants
  • Interests:Model trains OO gauge. C3 Picasso, Grandchildren

Posted 15 January 2013 - 03:56 PM

I recall that if the dip and the main beam are in the same bulb then only one is lit at a time. If the dips are separate bulbs then BOTH will be on on MAIN.


17 Reg C3 Saloon Flair 1.2 110BHP
Previous Xsara Picasso 20HDi, C3 SX 1.4HDi, C3 SX 1.6HDI, C4 Picasso 1.6HDi VTR+ EGS 62 Reg C3 Picasso VTR+ 1.6 HDi 92BHP

#4 kathemmi

kathemmi

    16 LX Newbie

  • Members
  • Pip
  • 7 posts

Posted 15 January 2013 - 05:47 PM

Thanks for your replies - the problem is when main beam is activated all lights except for side lights go out & there is no main beam or dip, just a very dark road.

The bulbs are new & as they do flash in main beam once after the ignition is switched off they must be OK.



#5 chili1496

chili1496

    18 HDI LX

  • Members
  • PipPip
  • 63 posts
  • Gender:Male

Posted 15 January 2013 - 06:12 PM

ah right, thats not too clever.



#6 Hank van de Weg

Hank van de Weg

    16 LX Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male

Posted 08 April 2019 - 08:09 AM

Any resolution to this? Where are the light relays located?

#7 stimulator

stimulator

    1.6 Cherry Red Metallic, wonder car

  • Members
  • PipPipPipPipPip
  • 9,600 posts
  • Gender:Male
  • Location:Waterlooville Hants
  • Interests:Model trains OO gauge. C3 Picasso, Grandchildren

Posted 09 April 2019 - 12:23 PM

Iirc they are in the BSI.
17 Reg C3 Saloon Flair 1.2 110BHP
Previous Xsara Picasso 20HDi, C3 SX 1.4HDi, C3 SX 1.6HDI, C4 Picasso 1.6HDi VTR+ EGS 62 Reg C3 Picasso VTR+ 1.6 HDi 92BHP





Also tagged with one or more of these keywords: light problem, main beam